読者です 読者をやめる 読者になる 読者になる

IT練習ノート

IT関連で調べたこと(実際は嵌ったこと)を書いています。

Warning:Gradle version 2.10 is required. Current version is 2.8

経緯

Android Studio 2.0 でのgradleのビルドエラーが発生しました。

Warning:Gradle version 2.10 is required. Current version is 2.8. If using the gradle wrapper, try editing the distributionUrl in ...hoge...\myproject\gradle\wrapper\gradle-wrapper.properties to gradle-2.10-all.zip

一週間前は、下記の情報で対応ができました。

qiita.com

今週、動作させると、似たようなエラー(ログは消してしまった、、)が出てビルドができませんでした。

stackoverflow.com

対処

build.gradleのclass pathの最新を指定。

    dependencies {
        classpath 'com.android.tools.build:gradle:2.0.0-alpha6'

最新は下記を確認します。

tools.android.com

gradle-wrapper.properties でgradleのバージョンを指定する。

distributionUrl=https\://services.gradle.org/distributions/gradle-2.10-all.zip

これでうまくいきそうですが、それでも同様なエラーが出ます。

仕方ないので、gradle-2.10-all.zipを直接ダウンロードして、下記のように配置しました。(旧バージョンは削除は試していません。)

f:id:naotoogawa:20160123213309p:plain